Planned Downtime - Upgrading servers. Back in 5 mins.
Incident Report for AnswerThePublic
Resolved
This incident has been resolved.
Posted Apr 06, 2020 - 08:35 UTC
Investigating
We are currently investigating this issue.
Posted Apr 06, 2020 - 08:30 UTC
This incident affected: Application and Data.